viernes, 12 de junio de 2015

PPPoE

!
! Cliente1
hostname Cust1
interface Ethernet0/0
pppoe enable group global
pppoe-client dial-pool-number 1
no shut
interface Dialer1
mtu 1492
ip address negotiated
encapsulation ppp
dialer pool 1
ppp authentication chap callin
ppp chap hostname Cust1
ppp chap password 0 ciscopppoe
ip route 0.0.0.0 0.0.0.0 Dialer1

!Server
hostname ISP
username Cust1 password 0 ciscopppoe
bba-group pppoe global
virtual-template 1
interface Ethernet0/0
pppoe enable group global
no shut
interface Virtual-Template1
ip address 10.0.0.254 255.255.255.0
mtu 1492
peer default ip address pool PPPoEPOOL
ppp authentication chap callin
ip local pool PPPoEPOOL 10.0.0.1 10.0.0.10
ip forward-protocol nd

Cust1#sh ip int br | se up
Ethernet0/0                   unassigned      YES NVRAM  up                    up    
Dialer1                         10.0.0.1           YES IPCP         up                    up    
Virtual-Access1            unassigned      YES unset         up                    up    
Virtual-Access2            unassigned      YES unset         up                    up    


Cust1#sh interfaces dialer 1
Dialer1 is up, line protocol is up (spoofing)
  Hardware is Unknown
  Internet address is 10.0.0.1/32
  MTU 1492 bytes, BW 56 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Closed, loopback not set


Cust1#show pppoe session
     1 client session

Uniq ID  PPPoE  RemMAC          Port                    VT  VA         State
                    SID  LocMAC                                      VA-st      Type
    N/A           55  aabb.cc00.0200  Et0/0                   Di1 Vi2        UP    
                            aabb.cc00.0100                              UP  



jueves, 30 de abril de 2015

IP SLA


IP SLA



Se va a hacer un tracking del router R4 al ip 5.5.5.5 ( loopback R5) aplicada a la ruta estática a la 3.3.3.0

hostname R4
track 2 ip sla 2 reachability
interface Loopback0
 ip address 4.4.4.4 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.168.2.4 255.255.255.0
 duplex full
!
interface Serial1/0
 ip address 192.168.4.4 255.255.255.0
 serial restart-delay 0
ip route 3.3.3.0 255.255.255.0 192.168.4.5 track 2
ip route 3.3.3.0 255.255.255.0 192.168.2.3 10
ip route 5.5.5.0 255.255.255.0 192.168.4.5

ip sla 2
 icmp-echo 5.5.5.5
 frequency 10
ip sla schedule 2 life forever start-time now

miércoles, 29 de abril de 2015

PPPoE Multilink

PPPoe  Multilink







hostname R1
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 pppoe enable group global
 pppoe-client dial-pool-number 1
!
interface Dialer1
 ip address negotiated
 ip mtu 1454
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname cisco
 ppp chap password 0 cisco
!
router ospf 1
 network 1.1.1.0 0.0.0.255 area 0
 network 192.168.1.0 0.0.0.255 area 0


hostname R2
!
username cisco password 0 cisco

bba-group pppoe global
 virtual-template 1
!
bba-group pppoe test
 virtual-template 1
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.0
!
interface Multilink1
 ip address 172.19.11.2 255.255.255.0
 ppp multilink
 ppp multilink group 1
!
interface FastEthernet0/0
 no ip address
 pppoe enable group test
!
interface Serial1/0
 no ip address
 encapsulation ppp
 ppp multilink
 ppp multilink group 1
!
interface Serial1/1
 no ip address
 encapsulation ppp
 ppp multilink
 ppp multilink group 1
!
interface Serial1/2
 no ip address
 encapsulation ppp
 ppp multilink
 ppp multilink group 1
!
interface Serial1/3
 no ip address
 encapsulation ppp
 ppp multilink
 ppp multilink group 1
!
interface Virtual-Template1
 mtu 1454
 ip address 192.168.1.2 255.255.255.0
 peer default ip address pool test1
 ppp authentication chap
!
router ospf 1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
!
ip local pool test1 192.168.1.10 192.168.1.19



hostname R3
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.0
!
interface Multilink1
 ip address 172.19.11.3 255.255.255.0
 ppp multilink
 ppp multilink group 1
!
interface FastEthernet0/0
 ip address 192.168.2.3 255.255.255.0
!
interface FastEthernet0/1
 no ip address
 shutdown
!
interface Serial1/0
 no ip address
 encapsulation ppp
 serial restart-delay 0
 ppp multilink
 ppp multilink group 1
!
interface Serial1/1
 no ip address
 encapsulation ppp
 ppp multilink
 ppp multilink group 1
!
interface Serial1/2
 no ip address
 encapsulation ppp
 ppp multilink
 ppp multilink group 1
!
interface Serial1/3
 no ip address
 encapsulation ppp
 ppp multilink
 ppp multilink group 1
!
interface Group-Async1
 physical-layer async
 no ip address
 encapsulation ppp
 ppp multilink
!
router ospf 1
 network 0.0.0.0 255.255.255.255 area 0
!